Auto assign threads

When I set up scenes using threads, if I insert a new scene with a different thread it automatically makes all the scenes following with the new thread, and not the one they were originally set up with. It’s driving me nuts - how do I stop it from happening?

2 Likes

Hi,

When you create a scene, have you selected the chapter you wish to insert the scene into? That way, the scene should appear under the Chapter, in the thread that the Chapter is assigned to.

Here’s a quick video:

Video

creating scenes timeline

You can read more about Scenes in the Timeline here: The Timeline – Papyrus Author

Hope this helps!

Sorry Sam but I don’t use chapters, and anyway it wouldn’t help because I organise my threads in character viewpoints, and that can change within a chapter. So, to be clear: I set up 5 scenes for John, then after the second one put in a scene for Sam, and it changes the next 3 to Sam’s thread as well. I think it’s auto assigning but I can’t work out how to turn that off. To be clear, I don’t use the timeline feature, just the threads.

Hi, thanks for the reply!

Do you mean, you don’t use the times in the Timeline, or that you don’t manage your threads in the Timeline feature either, but in the Organizer for example?

I tried to reproduce this behavior, but didn’t quite get there. Can you please post a screenshot of your threads’ setup, or if you’re up for it, you can send a document with this setup over to me as a private message, and I can take a look. :slight_smile:

How to take a screenshot

Use the snipping tool or screenshot tool to take a photo with these instructions:

For Windows: Use Snipping Tool to capture screenshots

For macOS: Take a screenshot on your Mac

Any document received by us is treated confidentially and used exclusively to investigate the reported issue.

You can simply drag and drop a file to the “reply” field to attach a document to your reply.

Thanks, Sam - I am using the organiser to set up my scenes, assigning a thread to them there. I don’t go into the timeline feature at all because I find it a bit restrictive. As all my work is contracted and therefore confidential, I will message you a screenshot so you can see where I am applying the thread.

1 Like

Thank you for the clarification!

I got the screenshot. I’ll delve into this, and see what we can do. :mag:

Thanks for the patience while I checked for workarounds and options.

At the moment, Papyrus Author assigns new scenes the attribute “Auto Assign” because of how the Timeline manages scenes and events, and there’s no quick fix for it, unfortunately.

I can suggest the following workflow for creating scenes and changing each scene’s thread in the Organizer:

  1. Have the Organizer’s “Properties” tab open (you can toggle it in the bottom-right corner of the Organizer).
  2. Create a scene in the Organizer.
  3. Select the Scene’s ‘Thread’ in the info screen, and change it from “Auto Assign” to the thread you want.

After selecting the thread once, the “Auto Assign” attribute is turned off, and these cascading thread changes won’t happen again. :slight_smile:

Here’s a quick video on the process - I hope it helps!

Summary

Change Threads in Organizer

It’s super fun to see different approaches to writing with Papyrus Author - this is the first time ever I’ve seen the Organizer being used this way, and we’ll have to keep it in mind when we further develop the Timeline and the Organizer. :grin:

Thanks so much, Sam. I’ll give that a go next time I need to insert a new scene, although it does sound quite close to what I’ve been doing. I’ll log onto the topic and watch the video first though because I’m sure there’s an important step I’m missing!

Jane

[

](Eva Glyn – HarperCollins Publishers UK)[

](Jane Cable | Authors | Sapere Books)


|

  • |

| Sam Papyrus Author Team
November 16 |

  • | - |

Thanks for the patience while I checked for workarounds and options.

jane_202:

I don’t use chapters, and anyway it wouldn’t help because I organise my threads in character viewpoints, and that can change within a chapter.-- I think it’s auto assigning but I can’t work out how to turn that off. To be clear, I don’t use the timeline feature, just the threads.

At the moment, Papyrus Author assigns new scenes the attribute “Auto Assign” because of how the Timeline manages scenes and events, and there’s no quick fix for it, unfortunately.

I can suggest the following workflow for creating scenes and changing each scene’s thread in the Organizer:

  1. Have the Organizer’s “Properties” tab open (you can toggle it in the bottom-right corner of the Organizer).
  2. Create a scene in the Organizer.
  3. Select the Scene’s ‘Thread’ in the info screen, and change it from “Auto Assign” to the thread you want.

After selecting the thread once, the “Auto Assign” attribute is turned off, and these cascading thread changes won’t happen again. :slight_smile:

Here’s a quick video on the process - I hope it helps!

Summary (click for more details)

It’s super fun to see different approaches to writing with Papyrus Author - this is the first time ever I’ve seen the Organizer being used this way, and we’ll have to keep it in mind when we further develop the Timeline and the Organizer. :grin: