Crash during renaming of the main timeline of a new document

When you create a new document and go into the timeline settings to rename the main timeline (in the German version its called “Hauptstrang”) Papyrus Author chrashes, if you click on the rename button without previously selecting the “Hauptstrang” entry. Unfortunately, this happens not every time I have tried it. So I hope this helps you nevertheless to find this bug. My experiences as a programmer suggest, that a Null-Pointer-Exception is probably the root of the problem here :slight_smile:



I couldn’t reproduce the crash, and can’t immediately see how it could happen.

If you don’t mind sharing what operating system you’re on, that’ll help a bunch, and I can try and dig more into this!

Do you go to change the name from the “Threads…” option the dropdown menu on a right click, or through the “Timeline Dates…” button?

Funny, I had the crash two times with the same workflow. But now I tried to reproduce it to be able to show it to you and everything works fine. Ok, it seems that it is not so easy as I thought to find this little wicked thing. Let it be. When I stumble over it again and can tell you exactly what I’ve done, I give you a hint :stuck_out_tongue_winking_eye: By the way, its not really a bad bug. If you select the main storyline first and press than rename, it works in any case.

1 Like