Hitting 'Enter' in form field does not allow newline to be inserted into text field

Operating System
Windows 10

Papyrus Author Version
Papyrus Author+ version 11.06b Win64 dated 2022-9-9

I am using the old forms for my character sheets. These forms are generated by the normal Sheets view and everything is default when it comes to the two fields I am talking about.

I wanted to input all of my characters into the database from existing word documents and I went to go edit their Appearance in the form and tried hitting enter to add a newline and instead it saves or “apply’s” the changes.

When I go down to the Ideas/Notes section, I can hit enter and add a newline like you would expect in a text editor.

I can also copy and paste text from the main editor into Appearance and it properly takes and displays the newlines. So for some reason these Text fields are hijacking the event of “hitting enter” and I am not sure why.

I checked the properties of both values and they are both classified as “Text”. All of the other values and check boxes are the same. Something in these forms is getting all of the other Text fields to behave differently than the Notes field. What setting do I need to select to get all of the text boxes to allow newlines?

  1. Open Database > Field Properties
  2. Select the field which currently doesn’t accept newlines
  3. Select the Values tab
  4. Check “Multi line edit (accepts line feeds)”
  5. Click “Update Table”

If you need to update several fields just do so, omitting step 5 and click Update Table at the very end. All fields will then be updated in one go.


So I was looking in the right area, but I was looking at Ideas_Text which did not have that box checked. So I thought they were all the same. I found another field called “ideas” which has this box checked, so I think I was looking at the wrong field. Ideas_Text might have been the label or something? Im not exactly sure how it was created.

Either way, now that I found the right field, this solved my problem!


1 Like

In the template for the My Characters database there is an “ideas” field but no “ideas_text” field. Perhaps you duplicated or created this field while playing around in this window. It takes a bit of time and practice to understand how it works.

Labels do not have a field in the database, only data fields have.

That makes sense. I probably did duplicate it or something.

Thanks for the quick feedback.

The “Ideas_Text” field in fact is created automatically when some text is fed into the “Ideas” section of the sheet. It is different from the “Ideas” field in the fields/table definition, which is labelled “Ideas and Notes” in the form.

1 Like