Odd distraction free behavior

Don’t know if this is how it should work, or is two bugs I found.

When going into distraction mode, the text on the screen is smaller (too small for me) compared to what it was while in edit mode.

Second issue is upon exiting distraction mode, shouldn’t it return to the edit window in the size the edit window was before invoking distraction free? It doesn’t and shrinks the window significantly. Screen shot below.


Sounds like your zoom level is too small in Distraction Free. Distraction Free Mode has its own independent settings, so the zoom level can be different from what you have in the regular writing view.

You can zoom in with holding down ⌘Command, and rolling the wheel of your mouse. If you’re on trackpad, hold down ⌘Command, and drag up and down with two fingers on the pad to find a comfortable zoom level.

For Windows: The zoom can be controlled with holding down CTRL and scrolling.

This is interesting. :thinking:

After exiting Distraction Free Mode, the normal view should be as you left it.

I can’t reproduce this behavior on my 13.4.1 Ventura. Which mac/macOS are you using?

Thanks for bringing this up!

I tried this again on both my MacBook and iMac, and both return to PA in the same size window now. The Macbook, at least all day yesterday, would return from distraction free mode to a shrunken window. It’s okay now… and one of those “don’t ask why, just be happy it’s fixed” moments. BTW, both are Ventura 13.4.1

The zoom feature works fine on the iMac (mouse adjustment), but is a nightmare on the Macbook. Extremely touchy on the touchpad/two fingers. First try ended in microsecond with a thin line down the screen which was about 40 pages all at once in distraction mode! Got the hang of it after half a dozen attempts, but not something I’d want to do each time. In brief test going back and forth the zoom setting held in distraction mode, and hopefully that’s not just for the current session, but whenever launching PA.

Think you should consider a zoom setting in the preferences instead of these manual zoom gestures.

Thanks as always for the quick and excellent support!

Follow my writing at:

Well, window size sticking was short lived. Afternoon session on Macbook and it’s back to a small window coming back from df mode. Guess it’s just a live-with thing since it’s inconsistant.

I’ve made a note of this behavior, and I’ll try to see what could be causing it.

If anyone else is experiencing this, I’d love to hear about it! :construction_worker_man: :wrench:

I’m on Win 11. When I leave distraction free mode my window sort of flashes then snaps to the right size.

1 Like