Search PA Projects via Windows Search

I have numerous Papyrus Author ¶ projects underway. Inasmuch as these projects are related, some share words and phrases. At least once a day I need to identify all projects containing a specific word or phrase. Rather than opening each project and searching for my the desired word/phrase, I tried using Windows Search (WS) on the top-level directory which contains all projects. Search subfolders is enabled in WS. Likewise, all other search parameters are correct. Why does Windows not parse the *.pap files and return the results? Are the PA files containing the words/phrases I seek stored elsewhere?

I’ve actually never thought of this! :exploding_head:

In my Windows 11 machine, I had to add pap as a file type that can be indexed. After that, I got a hit when searching for a word inside of a .pap file with Windows Search. Here’s how:

  1. Go to Settings in your Windows.
  2. Search for “Indexing Options”, and open it.
  3. Choose “:shield: Advanced”, and open the “File Types” tab.
  4. Add pap as a new extension, and click “add”.
    :bulb: Depending on your indexing settings, it can take a while for this to apply

→ After adding the filetype, and choosing “Index Properties and File Contents”, the search should work.

Let me know how it goes! :wrench: :man_construction_worker:

Thank you for the reply. My Explorer settings prescribed that pap files be indexed by Properties only. As per your recommendation, I changed the tick to Properties and Contents. Thank you for your assistance. I’ll let you know how it works out.

1 Like

Hi Sam,

I just tried this on my system, but there is a message ‘registered IFilter not found’, both for *.pap and *.pav files.

Interesting! :male_detective: :mag:

I didn’t find a 100% solution for this - there’s a bunch of topics on this message from Windows support resources, but there wasn’t a one-size-fits-all solution for it.

For a quick fix, can you check that your cumulative Windows Updates are up-to-date? Another solution I found was deleting and rebuilding your index, but it takes a long time to rebuild, so before that I’ll try to come up with another solution.

Can you also let me know which Windows build you have? :grin:

That’s Windows 11 Home, Vers. 23H2, build: 22631.3235

1 Like

Thanks for waiting - that took a while! :face_exhaling:

I tried to recreate a situation with my Windows 11 where I’d get the same error message, but couldn’t make it happen. :face_with_spiral_eyes:

I found a topic from MIcrosoft Support that sounds similar: Redirecting

:bulb: The solution here is adding an entry in the registry of your computer. Editing the registry can be tricky, and I recommend taking backups of pretty much everything before editing the registry. :jigsaw:

There’s more info on it in the link above. :wrench:

I’d also recommend checking out a few things I found could be related:

1. The Search Settings

  1. Go to your File Explorer, click the “…” icon and select :gear: Settings
  2. Check that “Include Compressed Files”, and “Always search file names and contents…” are selected.
  3. Click “Apply”.

2. Enhanced Search

  1. Go to your Windows Settings
  2. In “Privacy & Security”, open the “Searching Windows” tab
  3. Choose “Enhanced” in the “Find My Files” tab.

→ Restart your computer, and see if the search works for .pap files.

1 Like

I have written about this problem several times. To Mr. Ramps, to one of the programming team, on the FB forum, etc. The problem is because the ifilter located in the “modules” folder in the installation folder is incorrect or cannot be installed. This was extremely important to me because most of my texts were written ten, twenty or thirty years ago. I am a musicologist, and I need to search their content. Unfortunately content indexing is not possible. I also tried to implement the instructions given in this correspondence. And it doesn’t give results. It’s about time the Papyrus development team addressed this issue properly. With correct operation and installation of the ifilter. Greeting

Hi, and welcome to the Community! :raised_hands:

I don’t think we have a quick fix for this, but

Thanks for trying this out!

I’ll give changing the registry keys a go on my computer–I think changing the PersistentHandler could do the trick.

I’ll keep you posted! :construction_worker_man: :wrench:

Windows 11 Home Ver. 23H2 Build: 22631.3296

1 Like