System requirements?

Operating System

Papyrus Author Version

What are the system requirements for Papyrus Author? I can’t find them anywhere and though I’ve downloaded and installed it, it will not open though I’ve tried all the recommended stuff! I’m so super disappointed because I can tell I’m going to love it and I had plans to subscribe but at this point I cannot subscribe for something where the free version doesn’t even work!

Any Macintosh with macOS 10.13 or newer

or

Any Windows PC with 64-bit Windows 7 or newer should be fine.

Some people also run it on Linux using Play on Linux to run Windows applications.

Any plans on making an app for iPad Pro in the future?

Welcome to the Community.

We’re working on a mobile version right now :slight_smile:

1 Like