"Extract: error writing to file rt.jar"

I posted this on an older thread about the same issue, but because that thread has been inactive for a few years I feel like it’s worth creating a new post to make sure it gets attention. The exact text of that other post is quoted below.

“I’m having this issue with installation of the new version. Been using Papyrus for at least three years across several versions and never had this problem before. I initially thought it was due to lack of space, so I went ant deleted several GB worth of files about 100) and tried again, but the same error still occurs. And I don’t have an antivirus on my laptop because I couldn’t afford to pay after the trial period, so it’s not a matter of an overactive antivirus program. Tried deleting and redownloading installer several times but always the same thing. I have a lot of writing I’ve done with the previous versions of Papyrus Author that is now completely inaccessible to me because I can’t get the current version (the only WORKING version) to install. Since neither suggested fix in this thread applied, what can I do?”

The issue to which I am referring is the error message cited in the title of this post, which appears every time I try to install the new version of Papyrus Author. I already find it extremely frustrating that it seems I’m forced to download a new version of the program every few months, but now I’m not even able to install it any more, meaning that I am completely blocked from accessing my own writing as no other program (at least, not any I am able to find) is able to access Papyrus Author files. I am unable to add to, edit, share, or publish ANYTHING. If I could afford a fancy writing program, i would have switched long ago, but I have stuck with Papyrus Author in spite of the inconvenience or the ridiculously frequent new versions because I love the tools and utilities it offers that I just can’t get from other free writing software. Please tell me how to rectify this error so I can not only continue using the software, but access my work!

Hi @animeotakudrew!

Thanks for taking the first steps in troubleshooting! :raised_hands:

That error message “Extract: error writing to file rt.jar” usually pops up if the installer doesn’t have the necessary permissions to write in the location you’re trying to install to (the reason can be lack of space, an antivirus, or in this case, I think lack of write rights).

:bulb: Writing rights means the Papyrus Author installer has the permit from your computer to create and change files in the place you want to install the program.

You can give temporary writing rights to the installer by right-clicking on the installer and selecting ‘Run as administrator’.

:white_check_mark: If that doesn’t do the trick, you can try installing in a different location (eg. if you’re installing in C:-disk, try another hard drive).

I’m quite sure these will solve the problem, but if not, then let’s go to advanced troubleshooting:

Advanced troubleshooting

Your computer’s access rights may be very strict, and you’ll need to try logging in as an administrator account. You can read the steps here from Microsoft’s official support page: Redirecting

That way the folder you want to install to should have write rights, and the installation should go smoothly.

Let me know how it goes, and have fun with Papyrus Author! :man_construction_worker:

I finally got it installed. I don’t understand why because I couldn’t figure out how to do anything with administrator permissions or any of that (I’m on my personal laptop, on which I am the only user, so there is no administrator), so I didn’t really do anything different this time. It just finally decided to work.